Working with Architect flowcharts

From Insight-9.2

Contents

Viewing flowcharts

Architect lets you view flowcharts of a whole software source file or of a single entity (function, method, class or template) in a Klocwork project.

To view a flowchart, right-click an entity in the Project Tree view or Graphic view and click Show > Show Flowchart. The entity is displayed as a flowchart diagram in the Flowchart pane.

Architect flowchart view.jpg

For an explanation of the flowcharting symbols, see Standard flowcharting symbols and conventions.

Tips:

Click View > Show Shadow Map to display a watermark image of the complete Flowchart diagram behind the portion of an entity you are currently viewing in Flowchart. A gray box highlights the area of the diagram you are viewing within the complete flowchart. The gray box follows as you navigate around the diagram. To hide the shadow map, click View > Show Shadow Map again.

Click View > Show External Map to open a window displaying an image of the complete Flowchart diagram you are currently viewing. A green box highlights the area of the diagram visible in the Flowchart view. The green box follows as you navigate around the diagram. To hide the external map, click View > Show External Map again.

Viewing a function flowchart from within a file flowchart

To view a function flowchart from within a file flowchart:

  1. Open the flowchart for the file that contains the entity you want to see.
  2. Scroll through the flowchart and double-click the entity you want to see.
    Entities for which you can see a flowchart look like this within a file flowchart:
    Flowchart - entity.jpg

Tip: To return to the flowchart of the source file that contains the selected entity, click the Parent icon.

Navigating in Flowchart

Here are some navigational tips for flowcharts:

  • Use the Search > Find.... menu item to locate specific identifiers in a flowchart.
  • Click anywhere on the flowchart and drag to scroll through the flowchart.
  • The Line number box at the lower right corner of the Architect window displays the current line number.
  • Use the toolbar buttons and Flowchart menu items to get a better view of flowchart details. See Flowchart pop-up menu.
  • Use keyboard keys to navigate:
    Up arrow selects the symbol directly above the currently selected symbol and centers the diagram in relation to the newly selected symbol.
    Down arrow selects the symbol directly below the currently selected symbol and centers the diagram in relation to the newly selected symbol.
    Home key
    • in the file view, selects the first definition pattern and centers the diagram related to that newly selected pattern.
    • in the entity view, selects the start symbol and centers the diagram in relation to the newly selected symbol.
    End key
    • in the file view, selects the last definition pattern and centers the diagram in relation to the newly selected pattern.
    • in the entity view, selects the last return symbol and centers the diagram in relation to the newly selected symbol.
    Left arrow selects the previous branch in the pattern.
    Right arrow selects the next branch in the pattern.

Saving a graphical Flowchart snapshot

You can capture a snapshot of the portion of the flowchart currently displayed in the Flowchart pane. It is captured in portable network graphics (PNG) format.

To export a flowchart snapshot, while a Flowchart view is active, click File > Save to File.

Note: This procedure results in a snapshot of what is currently visible in the active Flowchart pane. To save a picture of the entire flowchart of a file or entity, use File > Print instead.

Printing a graphical Flowchart

You can print the graphical flowchart of a code file or entity to a PostScript file.

In a Flowchart view, display the flowchart that you want to print and click File > Print.

The PostScript file contains the flowchart of the entire file or entity you were viewing in Flowchart as well as a larger view of the portion of the flowchart that was visible in the display at the time you selected the Generate PostScript command.

Note for PC users: To view or print the flowchart on a PC, you need Acrobat Distiller, Ghostscript, or a similar program that allows you to view PostScript files.

Tip: Flowcharts saved to a file are saved in a readable size. Flowcharts that are very wide may be truncated. To capture a view of wide flowchart diagrams, use File > Export instead .

See also