Cannot connect to server - Unable to get Klocwork Server - Incompatible client version

From Insight-10.0

Desktop analysis > Cannot connect to server - Unable to get Klocwork Server - Incompatible client version

When you see this message, "Cannot connect to server: Unable to get project Klocwork Server at http(s)://<host>:<port>/<project>: Incompatible client version (<version>). Server version is <version>", it means that your Klocwork desktop analysis plug-in is incompatible with the Klocwork Server version.

The above message displays for Klocwork Desktop, IDE plug-in and kwcheck users when your connected desktop project fails to synchronize with the server project. Synchronization problems are indicated with this icon: Sync problem icon.png. Mousing over the icon displays the sync error message.

Contact your Klocwork administrator to find out where a compatible Klocwork desktop analysis installer is available.

Uninstall your current Klocwork desktop analysis plug-in version and then install the appropriate version.

You'll know Connected desktop and synchronization is working again when you see the Project is synchronized icon.png Project is synchronized icon.

See also